Supported Quickbooks Versions and Editions

1.  What are the supported versions of QuickBooks for integration with our JobNimbus?

The QuickBooks Sync integration works with two versions of Quickbooks: QuickBooks Online and QuickBooks Desktop.

2.  What editions are supported in JobNimbus for the QuickBooks Sync integration?
For QuickBooks Online:

  • Simple Start
  • Essentials
  • Plus

Self-employed is not supported.

For QuickBooks Desktop:

  • All enterprise editions.
  • Pro 2002 or later.
  • Premier 2002 or later.
  • Simple Start 2006 or later.

Accounting versions should sync as well. Quickbooks Mac edition is not supported due to the inability to add the Web Connector (program that transfers the data).

Certain aspects of non-US versions are unsupported, tax types must be tax or non for the code on the sales tax code list.

If you have a Quickbooks online trial and convert it to a paid account while syncing to JobNimbus. You should fully disconnect and reconnect the sync with the new paid for account. Quickbooks Online eventually deletes the trial data which could delete your JobNimbus data.